Cybersecurity
DevOps Cloud
IT Operations Cloud
Environment
ZENworks Service Desk v8.3.x, 23.x and higher
Situation
Configuring the ZSD system for Users to be using their own time zone in the requests and SLA calculations.
Example:
ZSD System in London, UK
The customer is located in Wales and set Wales holidays are set.
SLA should look to the targeted timer based on the holiday in the location the customer is in.
Configuring the SLA timezone to use the customers in Wales, because London and Wales have some different holidays.
Cause
Being able to configure the system for customers in various timezones.
Resolution
Step 1: For every SLA there will be option to Pause on Holiday, be sure to enable that option
Step 2: The User/Technician must be assigned with country.
Step 3: Holiday must be created for the country to which the User belongs.
Step 4: Under privileges -> user
Enable Obeserve public holidays option
The technician availability job runs every midnight, checks whether the next day is holiday.
If so, then increases the SLA for the request by one day and audit will be added to that request.