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Knowledge Document: Details on information / error message in Service Manager (SM) "Balancer Couldn't find any available nodes

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Environment

All versions of Service Manager (SM)
 

Situation

An informational / error message is observed in the SM system and log files:

JRTE I Balancer Couldn't find any available nodes. LoadBalancer is up, but none of the servers are ready to take the load.

Cause

This error message indicates that the load balancer is unable to find any available nodes to handle incoming requests. This could be due to a variety of reasons such as:

All nodes are currently busy processing requests, and none are available to take on additional load.
The nodes may be experiencing technical issues or outages that are preventing them from responding to requests.
The load balancer configuration may not be set up properly, preventing it from routing traffic to available nodes.
 

Resolution

To resolve this issue, check the status of the nodes to ensure that they are all up and running. If any nodes are experiencing issues, address those issues before attempting to use the load balancer.
Review the load balancer configuration to ensure that it is set up correctly and that traffic is being properly routed to the available nodes.
You may need to calculate the system load and scale up the infrastructure by adding additional nodes to handle the increased load. This will ensure that the load balancer always has available nodes to handle incoming requests.


Additional Information

For additional information check the topics and subtopics related to server implementation, loadbalancing, horizontal/vertical scaling, servlet implementation in the Online help documentation for your system version. 
For example:
https://docs.microfocus.com/doc/Service_Manager/9.72/ServerImplementationOptions

Access Service Manager article on support portal

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