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Knowledge Document: "No ticket available. Retry randomly" or "Exception: List index out of bounds (0)" with GW Archive Migration tool

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Environment

Micro Focus Retain 23.2
GroupWise 18.5

Situation

When attempting to import GW archived messages to Retain using the GW Archive Migration tool, the process fails with either of the following messages:

No ticket available. Retry randomly
or
[ERROR] Exception: List index out of bounds (0)

Cause

The Web Server on the Retain system is configured to redirect http requests to https.  The GW Archive Migration tool does not support https (SSL) connections to the Retain Server.

Resolution

Configure the GW Archive Migration tool to connect to the Retain Server over the non-SSL Tomcat port.  This is accomplished by editing the  serverURL element within the RetainWorker2.cfg as follows:

Original:


Changed:


Note the following differences

https to http
addition of :48080


By changing the RetainWorker2.cfg the "URL to connect to the Retain Server" value within the Connections tab of the GroupWise Personal Archive Migration Utility Configuration tool will reflect the modified URL (with http and port 48080).

Also, within the User List tab of the GroupWise Personal Archive Migration Utility Configuration tool, select the "Enable Multiple User Processing Using a Text File" box. In the "Users to Process" box, type in the UserID(s) of the user that you are attempting to import the archive for.

Additional Information

By using port 48080, the tool is no longer connecting through the Retain Webserver.  Instead, it is connecting over the Retain Tomcat service.

The GW Archive Migration tool supports SSL connections to the GW POA.

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