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Knowledge Document: Locked out of SMG Management Web UI due to certificate problems

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Environment
SLES15
Secure Messaging Gateway 7
Secure Messaging Gateway 23.x

Situation
None of the https (Secure HTTP) pages can load from the SMG server due to a problem with the certificate.


Cause
This problem could be the result of either:

  1. Uploaded a new certificate and rebooted the server prior to setting it as Active.
  2. The server powered up after a power outage. Secure Connection Failed is returned when attempting to load Secure HTTP pages.
  3. Some other problems with certificates.



Resolution
  Note:  It might be wise to make a snapshot backup of the SMG server, just as a precaution, before this tid is implemented.


Reset the SMG certificate to a new Self-Signed Certificate using the CLI.

Paste the following string of commands in a terminal session (putty or other tool):


systemctl stop smg;systemctl stop vabase-jetty;mv /vastorage/conf/certs/keystore /vastorage/conf/certs/keystore-backup;mv /vastorage/conf/certs/keystore.db /vastorage/conf/certs/keystore.backup;wget -P /tmp https://support.microfocus.com/kb/knova/images/va_firstboot_setupCerts.sh;chmod +x /tmp/va_firstboot_setupCerts.sh;/tmp/va_firstboot_setupCerts.sh;systemctl start vabase-jetty;systemctl start smg

Additional Information
    Note: If you cannot SSH to the server, run the following command at the terminal through a VMware tool:

            
rcsshd start
 

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