Cybersecurity
DevOps Cloud
IT Operations Cloud
Summary
Resolving "The application has failed to start because its side-by-side configuration is incorrect." error when launching Passsync Troubleshooting tool
Products
Identity Manager (IDM)
Environment
Identity Manager 4.8
Passsync Troubleshooting tool on IDM 4.8 Windows ISO under \IdentityManagerServer\products\IDM\windows\setup\utilities\PassSync Troubleshooting Tool
Situation
When attempting to launch the PassSync Troubleshooting Tool, the following error is received.
The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.
Passsync Troubleshooting Tool error
Running sxstrace provides the following detail on the error:
\IdentityManagerServer\products\IDM\windows\setup\utilities\PassSyncTroubleshootingTool\x64\D:\IdentityManagerServer\products\IDM\windows\setup\utilities\PassSyncTroubleshootingTool\x64\PassSync Troubleshooting Tool.exeen-USenTÀ¤ˆGbWС£¢L¬�J¼ÓÛiû¥¯ünhßD:\IdentityManagerServer\products\IDM\windows\setup\utilities\PassSyncTroubleshootingTool\x64\PassSync Troubleshooting Tool.exeDÀ¤ˆDcWС£¢L¬�J¼ÓÛiû¥¯ürhßMicrosoft.VC80.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762"DÀ¤ˆ–cWС£
Cause
The Logon-event Scanner software requires Microsoft.VC80.CRT version 8.0.50727.762 in order to run.
Resolution
Install the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update to add the 8.0.50727.762 files to the server.
https://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=26347
URL Name
KM000010883