Cybersecurity
DevOps Cloud
IT Operations Cloud
Summary
Unable to perform amrestore for Admin Console configuration for NAM 4.5.6.1
Products
Access Manager (NAM)
Environment
NetIQ Access Manager 4.5.6.1
Windows Server 2016
Situation
When we try to do amrestore for windows version of NAM 4.5.6.1, we get below error:
Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/logging/log4j/core/Layout at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2701) at java.lang.Class.privateGetMethodRecursive(Class.java:3048) at java.lang.Class.getMethod0(Class.java:3018) at java.lang.Class.getMethod(Class.java:1784) at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:650) at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:632) Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.core.Layout at java.net.URLClassLoader.findClass(URLClassLoader.java:382) at java.lang.ClassLoader.loadClass(ClassLoader.java:418) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352) at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ... 7 more
Cause
Required jar files missing in class path.
Resolution
Please contact support for assistance in obtaining the missing jar file.
URL Name
KM000017009